summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-30 22:19:35 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-30 22:19:35 +0200
commitd274f499a35f416d49533c0d1e2b76cb3cebdcb8 (patch)
tree82c313654c19439013b7d3ff6914612d5de38f32 /gnu/packages/glib.scm
parent9ceb630c587beb187b52243f751e3ebc2b437a32 (diff)
downloadpatches-d274f499a35f416d49533c0d1e2b76cb3cebdcb8.tar
patches-d274f499a35f416d49533c0d1e2b76cb3cebdcb8.tar.gz
gnu: glib: Update to 2.38.0.
* gnu/packages/glib.scm (glib): Update to 2.38.0 and drop rewriting of GTESTER. * gnu/packages/patches/glib-tests-homedir.patch: Update patch for 2.38.0. * gnu/packages/patches/glib-tests-desktop.patch: Update patch for 2.38.0 and drop test dbus-appinfo.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a6b86795a8..cfaea3b958 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -105,14 +105,14 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
- (version "2.37.1")
+ (version "2.38.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
- name "/2.37/"
+ name "/" (string-take version 4) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1lp705q0g9jlfj24x8fpgjh7awmmara5iyj9kz5lhd49sr9s813k"))))
+ (base32 "0cpzqadqk6z6bmb79p04pykxc8x57rvshh33414cnk41bvgaf4vm"))))
(build-system gnu-build-system)
(outputs '("out" ; everything
"doc")) ; 20 MiB of GTK-Doc reference
@@ -153,13 +153,7 @@ shared NFS home directories.")
"glib/tests/utils.c"
"tests/spawn-test.c")
(("/bin/sh")
- (string-append (assoc-ref inputs "bash") "/bin/sh")))
-
- ;; Honor $(TESTS_ENVIRONMENT).
- (substitute* (find-files "." "^Makefile(\\.in)?$")
- (("^GTESTER[[:blank:]]*=(.*)$" _ rest)
- (string-append "GTESTER = $(TESTS_ENVIRONMENT) "
- rest))))
+ (string-append (assoc-ref inputs "bash") "/bin/sh"))))
%standard-phases)
;; Note: `--docdir' and `--htmldir' are not honored, so work around it.