summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-02 18:00:41 +0800
committerLudovic Courtès <ludo@gnu.org>2016-04-16 11:43:54 +0200
commit7dd99e5573581d391e2318a4b1a314e593ee0541 (patch)
treee18f64415396d9359d808be0a3c20748065bc20d /gnu/packages/glib.scm
parent0f795a0a539fbaed8cda95d9575a5cfdec62b83f (diff)
downloadpatches-7dd99e5573581d391e2318a4b1a314e593ee0541.tar
patches-7dd99e5573581d391e2318a4b1a314e593ee0541.tar.gz
gnu: glib: Drop glib-tests-homedir.patch.
* gnu/packages/glib.scm (glib)[source]: Remove glib-tests-homedir.patch. [arguments]: Set HOME and disable '/gdbus/codegen-peer-to-peer' test. * gnu/packages/patches/glib-tests-homedir.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 523116d8ac..13f3f3a8a2 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -138,8 +138,7 @@ shared NFS home directories.")
(sha256
(base32
"1yzxr1ip3l0m9ydk5nq32piq70c9f17p5f0jyvlsghzbaawh67ss"))
- (patches (search-patches "glib-tests-homedir.patch"
- "glib-tests-desktop.patch"
+ (patches (search-patches "glib-tests-desktop.patch"
"glib-tests-prlimit.patch"
"glib-tests-timer.patch"
"glib-tests-gapplication.patch"))))
@@ -170,6 +169,7 @@ shared NFS home directories.")
"/share/zoneinfo"))
;; Some tests want write access there.
+ (setenv "HOME" (getcwd))
(setenv "XDG_CACHE_HOME" (getcwd))
(substitute* '("glib/gspawn.c"
@@ -178,6 +178,9 @@ shared NFS home directories.")
(("/bin/sh")
(string-append (assoc-ref inputs "bash") "/bin/sh")))
+ ;; Disable a test that requires /etc/machine-id.
+ (substitute* "gio/tests/gdbus-peer.c"
+ (("g_test_add_func.*/gdbus/codegen-peer-to-peer.*") ""))
;; Disable a test that requires dbus.
(substitute* "gio/tests/gdbus-serialization.c"
(("g_test_add_func \