summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-09-10 11:02:16 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-10-21 11:08:32 +0900
commit7da3e81aa1b95ba2d72118e393c4531da44d5536 (patch)
treecd1d3db0bc57a827f22d3531ae8a5be657aaee08 /gnu/packages/glib.scm
parent47f4df157f999a361fb1d37c07a82f2089fffb4d (diff)
downloadpatches-7da3e81aa1b95ba2d72118e393c4531da44d5536.tar
patches-7da3e81aa1b95ba2d72118e393c4531da44d5536.tar.gz
gnu: glib: Reference dbus-launch by its absolute path.
* gnu/packages/glib.scm (glib)[phases]{patch-dbus-launch-path}: New phase.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index c558d9fcb6..62f09436a2 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -201,6 +201,14 @@ shared NFS home directories.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-dbus-launch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((dbus (assoc-ref inputs "dbus")))
+ (substitute* "gio/gdbusaddress.c"
+ (("command_line = g_strdup_printf \\(\"dbus-launch")
+ (string-append "command_line = g_strdup_printf (\""
+ dbus "/bin/dbus-launch")))
+ #t)))
(add-before 'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)
;; For tests/gdatetime.c.