summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-14 11:21:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-16 17:31:11 +0200
commit78acbcb53fa3595c15f2ed0bfe7bedb7cbb09a29 (patch)
treed1d7b347d5fb8508ff496ebcf7aa59742b532897 /gnu/packages/gl.scm
parentc533589c66b373b5bc3049415858094d17b44b0b (diff)
downloadpatches-78acbcb53fa3595c15f2ed0bfe7bedb7cbb09a29.tar
patches-78acbcb53fa3595c15f2ed0bfe7bedb7cbb09a29.tar.gz
gnu: Add nanovg-for-extempore.
* gnu/packages/gl.scm (nanovg-for-extempore): New variable.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1aa12017c6..707e3d4d1d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -573,3 +574,27 @@ OpenGL.")
desktop computers. It provides a simple API for creating windows, contexts
and surfaces, receiving input and events.")
(license license:zlib)))
+
+(define-public nanovg-for-extempore
+ (package
+ (name "nanovg-for-extempore")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/extemporelang/nanovg/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ivs1sagq19xiw8jxd9f8w2b39svi0n9hrbmdvckwvqg95r8701g"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("mesa" ,mesa)))
+ (home-page "https://github.com/extemporelang/nanovg")
+ (synopsis "2D vector drawing library on top of OpenGL")
+ (description "NanoVG is small antialiased vector graphics rendering
+library for OpenGL. It has lean API modeled after HTML5 canvas API. It is
+aimed to be a practical and fun toolset for building scalable user interfaces
+and visualizations.")
+ (license license:zlib)))