summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-23 21:28:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-23 21:32:27 +0300
commit5f8dd6dca8140aa44c9ea0c4a23e39770dda3ed3 (patch)
treea495c124b3bb857c15377e09a04f83dec11db9d8 /gnu/packages/gl.scm
parent70cf677c5c715b062333b2a42e58488c819ca067 (diff)
downloadpatches-5f8dd6dca8140aa44c9ea0c4a23e39770dda3ed3.tar
patches-5f8dd6dca8140aa44c9ea0c4a23e39770dda3ed3.tar.gz
gnu: libepoxy: Use 'modify-phases'.
* gnu/packages/gl.scm (libepoxy)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 6bdacffe11..1e751accda 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -465,32 +465,32 @@ OpenGL graphics API.")
"1d1brhwfmlzgnphmdwlvn5wbcrxsdyzf1qfcf8nb89xqzznxs037"))))
(arguments
`(#:phases
- (alist-cons-after
- 'unpack 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vif")))
- (alist-cons-before
- 'configure 'patch-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((python (assoc-ref inputs "python"))
- (mesa (assoc-ref inputs "mesa")))
- (substitute* "src/gen_dispatch.py"
- (("/usr/bin/env python") python))
- (substitute* (find-files "." "\\.[ch]$")
- (("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
- (("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
+ (modify-phases %standard-phases
+ (add-after
+ 'unpack 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vif"))))
+ (add-before
+ 'configure 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python (assoc-ref inputs "python"))
+ (mesa (assoc-ref inputs "mesa")))
+ (substitute* "src/gen_dispatch.py"
+ (("/usr/bin/env python") python))
+ (substitute* (find-files "." "\\.[ch]$")
+ (("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
+ (("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
- ;; XXX On armhf systems, we must add "GLIBC_2.4" to the list of
- ;; versions in test/dlwrap.c:dlwrap_real_dlsym. It would be
- ;; better to make this a normal patch, but for now we do it here
- ;; to prevent rebuilding on other platforms.
- ,@(if (string-prefix? "arm" (or (%current-target-system)
- (%current-system)))
- '((substitute* '"test/dlwrap.c"
- (("\"GLIBC_2\\.0\"") "\"GLIBC_2.0\", \"GLIBC_2.4\"")))
- '())
- #t))
- %standard-phases))))
+ ;; XXX On armhf systems, we must add "GLIBC_2.4" to the list of
+ ;; versions in test/dlwrap.c:dlwrap_real_dlsym. It would be
+ ;; better to make this a normal patch, but for now we do it here
+ ;; to prevent rebuilding on other platforms.
+ ,@(if (string-prefix? "arm" (or (%current-target-system)
+ (%current-system)))
+ '((substitute* '"test/dlwrap.c"
+ (("\"GLIBC_2\\.0\"") "\"GLIBC_2.0\", \"GLIBC_2.4\"")))
+ '())
+ #t))))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)