summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-20 19:54:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-20 19:55:34 +0200
commitcb6392698af08c1774e8a9f05cb09dcf0409e718 (patch)
tree70e1776aaab07ddd613a1ba86ecb645654d5dedf /gnu/packages/gl.scm
parent7c9b87600b9dc22bb0f5b74fb8b9a1fe7ba691c2 (diff)
downloadpatches-cb6392698af08c1774e8a9f05cb09dcf0409e718.tar
patches-cb6392698af08c1774e8a9f05cb09dcf0409e718.tar.gz
gnu: mesa: Update to 17.2.1.
* gnu/packages/gl.scm (mesa): Update to 17.2.1. [inputs]: Add WAYLAND-PROTOCOLS. * gnu/packages/patches/mesa-skip-disk-cache-test.patch: Adjust context.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index fa9b501077..9ce97dbcc2 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -217,7 +217,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "17.1.8")
+ (version "17.2.1")
(source
(origin
(method url-fetch)
@@ -229,7 +229,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1nv9aaz7ay2bs4fc8j3rf6ky3qla8s346a8g2lvdbp96msp2xvbm"))
+ "07msr6xismw2jq87irwhz7vygvzj6hi38d71paij9zvwh8bmsf3p"))
(patches
(search-patches "mesa-wayland-egl-symbols-check-mips.patch"
"mesa-skip-disk-cache-test.patch"))))
@@ -261,7 +261,8 @@ also known as DXTn or DXTC) for Mesa.")
("makedepend" ,makedepend)
("presentproto" ,presentproto)
("s2tc" ,s2tc)
- ("wayland" ,wayland)))
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python-2)