summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-18 23:40:54 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-19 15:54:10 +0200
commita966281f2da1a8b6bc45cbd208c28e39b05a0373 (patch)
treeb543ad4b480e4af18c3f3944cdc805bda702b723 /gnu/packages/gl.scm
parent7fee5b53973fb4fe049aa0bc5db58093727bdf30 (diff)
downloadpatches-a966281f2da1a8b6bc45cbd208c28e39b05a0373.tar
patches-a966281f2da1a8b6bc45cbd208c28e39b05a0373.tar.gz
gnu: glfw: Propagate the relevant inputs.
* gnu/packages/gl.scm (glfw)[inputs]: Rename to... [propagated-inputs]: ... this. Add LIBXXF86VM.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index a4ec3a3536..c40d100a93 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -561,12 +561,15 @@ OpenGL.")
(native-inputs
`(("doxygen" ,doxygen)
("unzip" ,unzip)))
- (inputs
- `(("mesa" ,mesa)
+ (propagated-inputs
+ `(("mesa" ,mesa) ;included in public headers
+
+ ;; These are in 'Requires.private' of 'glfw3.pc'.
("libx11" ,libx11)
("libxrandr" ,libxrandr)
("libxinerama" ,libxinerama)
- ("libxcursor" ,libxcursor)))
+ ("libxcursor" ,libxcursor)
+ ("libxxf86vm" ,libxxf86vm)))
(home-page "http://www.glfw.org")
(synopsis "OpenGL application development library")
(description