summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-22 06:29:21 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-22 07:26:04 +0100
commit827dc6295c3aafd592f3bb5fe151fdc4fd8d35b7 (patch)
treed7e6f653654bc234d2315625fc1323ebdf91bd0a /gnu/packages/gl.scm
parenta6d352cc017e30fec2301cdf7b496ab630ba0a41 (diff)
downloadpatches-827dc6295c3aafd592f3bb5fe151fdc4fd8d35b7.tar
patches-827dc6295c3aafd592f3bb5fe151fdc4fd8d35b7.tar.gz
gnu: libepoxy: Update to 1.4.0.
* gnu/packages/patches/libepoxy-gl-null-checks.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/gl.scm (libepoxy): Update to 1.4.0. [source]: Remove patch. Use release tarball and remove explicit file-name. [arguments]: Drop 'autoreconf' phase. Remove obsolete test substitution. [native-inputs]: Remove AUTOCONF, AUTOMAKE and LIBTOOL.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm30
1 files changed, 6 insertions, 24 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 775d656e17..53f720ac2a 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -456,25 +456,20 @@ OpenGL graphics API.")
(define-public libepoxy
(package
(name "libepoxy")
- (version "1.3.1")
+ (version "1.4.0")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/anholt/libepoxy/archive/v"
+ "https://github.com/anholt/libepoxy/releases/download/v"
+ (version-major+minor version) "/libepoxy-"
version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ ".tar.xz"))
(sha256
(base32
- "1d1brhwfmlzgnphmdwlvn5wbcrxsdyzf1qfcf8nb89xqzznxs037"))
- (patches (search-patches "libepoxy-gl-null-checks.patch"))))
+ "0hdbaapbxjjfdqsdvag460kfjvs800da5sngi2sc46wj9aqhda95"))))
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after
- 'unpack 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vif"))))
(add-before
'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -485,23 +480,10 @@ OpenGL graphics API.")
(substitute* (find-files "." "\\.[ch]$")
(("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
(("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
-
- ;; XXX On armhf systems, we must add "GLIBC_2.4" to the list of
- ;; versions in test/dlwrap.c:dlwrap_real_dlsym. It would be
- ;; better to make this a normal patch, but for now we do it here
- ;; to prevent rebuilding on other platforms.
- ,@(if (string-prefix? "arm" (or (%current-target-system)
- (%current-system)))
- '((substitute* '"test/dlwrap.c"
- (("\"GLIBC_2\\.0\"") "\"GLIBC_2.0\", \"GLIBC_2.4\"")))
- '())
#t))))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
+ `(("pkg-config" ,pkg-config)
("python" ,python)))
(inputs
`(("mesa" ,mesa)))