summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorL p R n d n <guix@lprndn.info>2020-03-24 14:34:22 +0100
committerGuix Patches Tester <>2020-03-24 15:55:09 +0000
commite4c5d213e9861c55132398119b960e4ae069df3f (patch)
tree851867fd49c0a82bcaaaf6e79a6c7dd913ad77d5 /gnu/packages/gimp.scm
parent8465f1f680ee67c2cca265d1c5871b46284f55f9 (diff)
downloadpatches-e4c5d213e9861c55132398119b960e4ae069df3f.tar
patches-e4c5d213e9861c55132398119b960e4ae069df3f.tar.gz
gnu: libmypaint: Update to 1.5.1.series-3283
* gnu/packages/gimp.scm (libmypaint): Move variable to gnu/packages/drawing.scm. * gnu/packages/drawing.scm: New file. * gnu/local.mk: Register it. * gnu/packages/drawing.scm (libmypaint): Update to 1.5.1.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index fcf613423c..0d9b2ec023 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages pdf)
#:use-module (gnu packages photo)
+ #:use-module (gnu packages drawing)
#:use-module (gnu packages python)
#:use-module (gnu packages web)
#:use-module (gnu packages xorg))
@@ -264,34 +265,6 @@ can draw or apply filters in fourier space and get the modified image with an
inverse fourier transform.")
(license license:gpl3+)))
-(define-public libmypaint
- (package
- (name "libmypaint")
- (version "1.3.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mypaint/libmypaint/"
- "releases/download/v" version "/libmypaint-"
- version ".tar.xz"))
- (sha256
- (base32
- "0wd6jk69vmhsq1mdw96v0fh7b28n3glkr5ca466zcq7agzaxj1va"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
- ;; As needed by 'libmypaint.pc'.
- (propagated-inputs
- `(("json-c" ,json-c)
- ("gobject-introspection" ,gobject-introspection)))
- (inputs
- `(("glib" ,glib)))
- (synopsis "Artistic brushes library")
- (description "Libmypaint, also called \"brushlib\", is a library for making
-brushstrokes which is used by MyPaint and GIMP.")
- (home-page "http://mypaint.org")
- (license license:isc)))
-
(define-public mypaint-brushes
(package
(name "mypaint-brushes")