summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-29 22:16:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:58:59 +0100
commitc751e5c6bba28365073c99bdbebf4c64b382dce5 (patch)
tree46b67c19052fcf3a16b6d80416b6bb36681092c6 /gnu/packages/ghostscript.scm
parente554eba02c8f5fc090ca54476a0ad6a1de9cc5c0 (diff)
downloadpatches-c751e5c6bba28365073c99bdbebf4c64b382dce5.tar
patches-c751e5c6bba28365073c99bdbebf4c64b382dce5.tar.gz
gnu: ghostscript: Incorporate grafted changes.
* gnu/packages/ghostscript.scm (ghostscript)[replacement]: Remove field. [arguments]: Add "--disable-compile-inits" and "--with-fontpath" in #:configure-flags. [native-inputs]: Add PKG-CONFIG. [inputs]: Add FONTCONFIG and GS-FONTS. (ghostscript/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm34
1 files changed, 8 insertions, 26 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 7839ac5b72..224a83641b 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -157,12 +157,6 @@ printing, and psresize, for adjusting page sizes.")
(package
(name "ghostscript")
(version "9.27")
-
- ;; The problems addressed by GHOSTSCRIPT/FIXED are not security-related,
- ;; but they have a significant impact on usability, hence this graft.
- ;; TODO: Ungraft on next update cycle.
- (replacement ghostscript/fixed)
-
(source
(origin
(method url-fetch)
@@ -205,6 +199,10 @@ printing, and psresize, for adjusting page sizes.")
(string-append "ZLIBDIR="
(assoc-ref %build-inputs "zlib") "/include")
"--enable-dynamic"
+ "--disable-compile-inits"
+ (string-append "--with-fontpath="
+ (assoc-ref %build-inputs "gs-fonts")
+ "/share/fonts/type1/ghostscript")
,@(if (%current-target-system)
'(;; Specify the native compiler, which is used to build 'echogs'
@@ -268,6 +266,7 @@ printing, and psresize, for adjusting page sizes.")
#t))))))
(native-inputs
`(("perl" ,perl)
+ ("pkg-config" ,pkg-config) ;needed for freetype
("python" ,python-wrapper)
("tcl" ,tcl)
@@ -278,7 +277,9 @@ printing, and psresize, for adjusting page sizes.")
("libjpeg/native" ,libjpeg))
'())))
(inputs
- `(("freetype" ,freetype)
+ `(("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("gs-fonts" ,gs-fonts)
("jbig2dec" ,jbig2dec)
("libjpeg" ,libjpeg)
("libpaper" ,libpaper)
@@ -294,25 +295,6 @@ output file formats and printers.")
(home-page "https://www.ghostscript.com/")
(license license:agpl3+)))
-(define ghostscript/fixed
- ;; This adds the Freetype dependency (among other things), which fixes the
- ;; rendering issues described in <https://issues.guix.gnu.org/issue/34877>.
- (package/inherit
- ghostscript
- (arguments
- (substitute-keyword-arguments (package-arguments ghostscript)
- ((#:configure-flags flags ''())
- `(append (list "--disable-compile-inits"
- (string-append "--with-fontpath="
- (assoc-ref %build-inputs "gs-fonts")
- "/share/fonts/type1/ghostscript"))
- ,flags))))
- (native-inputs `(("pkg-config" ,pkg-config) ;needed for freetype
- ,@(package-native-inputs ghostscript)))
- (inputs `(("gs-fonts" ,gs-fonts)
- ("fontconfig" ,fontconfig)
- ,@(package-inputs ghostscript)))))
-
(define-public ghostscript/x
(package/inherit ghostscript
(name (string-append (package-name ghostscript) "-with-x"))