summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-24 20:42:48 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-24 20:42:48 +0200
commit99cfdfb10c7bf42911f2ff59ef3489761ebc063d (patch)
tree2ac8b22c52754ac9667770e63209b3a184a626b8 /gnu/packages/ghostscript.scm
parent5a0b3c34088d36ac03e705dea573f62f84d96f11 (diff)
downloadpatches-99cfdfb10c7bf42911f2ff59ef3489761ebc063d.tar
patches-99cfdfb10c7bf42911f2ff59ef3489761ebc063d.tar.gz
gnu: ghostscript: Incorporate grafted changes.
* gnu/packages/ghostscript.scm (ghostscript)[replacement]: Remove field. (source)[patches]: Add 'ghostscript-CVE-2018-10194.patch'. (ghostscript/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index bc14fd0be0..cd7cd604fd 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -132,7 +132,6 @@ printing, and psresize, for adjusting page sizes.")
(define-public ghostscript
(package
(name "ghostscript")
- (replacement ghostscript/fixed)
(version "9.23")
(source
(origin
@@ -145,6 +144,7 @@ printing, and psresize, for adjusting page sizes.")
(base32
"1ng8d9fm5lza7k1f7ybc791275c07z5hcmpkrl2i226nshkxrkhz"))
(patches (search-patches "ghostscript-runpath.patch"
+ "ghostscript-CVE-2018-10194.patch"
"ghostscript-no-header-creationdate.patch"
"ghostscript-no-header-id.patch"
"ghostscript-no-header-uuid.patch"))
@@ -251,16 +251,6 @@ output file formats and printers.")
(home-page "https://www.ghostscript.com/")
(license license:agpl3+)))
-(define-public ghostscript/fixed
- (hidden-package
- (package
- (inherit ghostscript)
- (source
- (origin
- (inherit (package-source ghostscript))
- (patches (append (origin-patches (package-source ghostscript))
- (search-patches "ghostscript-CVE-2018-10194.patch"))))))))
-
(define-public ghostscript/x
(package/inherit ghostscript
(name (string-append (package-name ghostscript) "-with-x"))