summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-24 17:54:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:37 +0100
commit5fcc5b38ed309ded75e52f54dc14b371f3a6bc96 (patch)
treeb3bdd3ed07d8472fdfe1b0c2128bec2643426dcb /gnu/packages/geo.scm
parentd040e650b2bfeb4ba25912f68f828b675c6b0464 (diff)
downloadpatches-5fcc5b38ed309ded75e52f54dc14b371f3a6bc96.tar
patches-5fcc5b38ed309ded75e52f54dc14b371f3a6bc96.tar.gz
gnu: qmapshack: Remove sqlite-with-column-metadata workaround.
* gnu/packages/geo.scm (qmapshack)[arguments]: Do not set LD_LIBRARY_PATH in wrapper scripts.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b5b6d9114e..5f9037a89f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1431,23 +1431,15 @@ using the dataset of topographical information collected by
(invoke "patch" "-p1" "-i" "FindQuaZip5.patch")
#t))
(add-after 'install 'wrap
- ;; The program fails to run with the error:
- ;; undefined symbol: sqlite3_column_table_name16
- ;; Forcing the program to use sqlite-with-column-metadata instead
- ;; of sqlite using LD_LIBRARY_PATH solves the problem.
- ;;
- ;; The program also fails to find the QtWebEngineProcess program,
+ ;; The program fails to find the QtWebEngineProcess program,
;; so we set QTWEBENGINEPROCESS_PATH to help it.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin"))
(qtwebengineprocess (string-append
(assoc-ref inputs "qtwebengine")
- "/lib/qt5/libexec/QtWebEngineProcess"))
- (sqlite-lib (string-append (assoc-ref inputs "sqlite")
- "/lib")))
+ "/lib/qt5/libexec/QtWebEngineProcess")))
(for-each (lambda (program)
(wrap-program program
- `("LD_LIBRARY_PATH" ":" prefix (,sqlite-lib))
`("QTWEBENGINEPROCESS_PATH" =
(,qtwebengineprocess))))
(find-files bin ".*")))