summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 01:42:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 01:42:02 +0100
commitbb4674b43fa413a6d41694b2093c3b00d11eea47 (patch)
treee9de75e813e90459c5313ba73ac22473b0e0e565 /gnu/packages/geo.scm
parent41c6e4f2b40f41cdbf4e8c7ade29845709f9cdf4 (diff)
parent989d564f4434c6e43df7ccb0d1701e89e243e404 (diff)
downloadpatches-bb4674b43fa413a6d41694b2093c3b00d11eea47.tar
patches-bb4674b43fa413a6d41694b2093c3b00d11eea47.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 05d177c3b1..0e5afdae30 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -776,7 +776,7 @@ extension.")
"cmd/tegola_lambda/main.go")
(("version not set") ,version)))
#t)))))
- (home-page "http://tegola.io")
+ (home-page "https://tegola.io")
(synopsis "Vector tile server for maps")
(description "Tegola is a free vector tile server written in Go. Tegola
takes geospatial data and slices it into vector tiles that can be efficiently
@@ -1523,3 +1523,29 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
tools supporting SpatiaLite.")
(home-page "https://www.gaia-gis.it/fossil/spatialite-tools/index")
(license license:gpl3+)))
+
+(define-public virtualpg
+ (package
+ (name "virtualpg")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.gaia-gis.it/gaia-sins/"
+ "virtualpg-" version ".tar.gz"))
+ (sha256
+ (base32 "0kjipcd08vvn188xmwbs7sw41xcs06x47n2hbqshpjcr51mxbarp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("postgresql" ,postgresql)
+ ("sqlite" ,sqlite)))
+ (synopsis "Allow SQLite/SpatiaLite to access PostgreSQL/PostGIS tables")
+ (description
+ "VirtualPG is a dynamic extension for the SQLite DBMS. It implements
+the VirtualPostgres driver, allowing to directly exchange data between SQLite
+and PostgreSQL; if SpatiaLite is available even PostGIS geometries can be
+exchanged form one Spatial DBMS and the other.")
+ (home-page "https://www.gaia-gis.it/fossil/virtualpg/index")
+ (license (list license:gpl2+
+ license:lgpl2.1+
+ license:mpl1.1))))