summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-17 16:24:09 -0500
committerLeo Famulari <leo@famulari.name>2018-03-15 10:57:50 -0400
commitebc4bd5b54260082a2897669668144467b856198 (patch)
tree79560cdf33630a6e3c9ad8900e8bee5b0ed88697 /gnu/packages/geo.scm
parent3d60f4265e3f89151aaf45bd238ce1c2c89790b5 (diff)
downloadpatches-ebc4bd5b54260082a2897669668144467b856198.tar
patches-ebc4bd5b54260082a2897669668144467b856198.tar.gz
gnu: Add r-mapproj.
* gnu/packages/geo.scm (r-mapproj): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 3af196bed3..e58342d62e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -511,3 +511,25 @@ development.")
Projection code and larger maps are in separate packages ('mapproj' and
'mapdata').")
(license license:gpl2)))
+
+(define-public r-mapproj
+ (package
+ (name "r-mapproj")
+ (version "1.2-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mapproj" version))
+ (sha256
+ (base32
+ "0rjz37r4rizk2c6jaf54f0kfb60dqv6b262cnhiwjl55d4x6l0pk"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-maps" ,r-maps)))
+ (home-page "https://cran.r-project.org/web/packages/mapproj")
+ (synopsis "Map projection in R")
+ (description "This package converts latitude/longitude into projected
+coordinates.")
+ (license (list license:gpl2 ; The R interface
+ (license:non-copyleft ; The C code
+ "https://www.gnu.org/licenses/license-list.en.html#lucent102"
+ "Lucent Public License Version 1.02")))))