summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-07 19:02:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-07 19:03:19 +0200
commit9fa7c20be969eee7fa04d94fafeac94818fff01a (patch)
tree8c37f8d54144b888fc424ed06c96dc3a46470eec /gnu/packages/geo.scm
parentfdc0688cba75b9ba1b83183cc978f8cc683499d4 (diff)
downloadpatches-9fa7c20be969eee7fa04d94fafeac94818fff01a.tar
patches-9fa7c20be969eee7fa04d94fafeac94818fff01a.tar.gz
gnu: gnome-maps: Fix runtime error.
Fixes <https://bugs.gnu.org/35761>. * gnu/packages/geo.scm (gnome-maps)[arguments]: Add lib output of gnome-online-accounts and geocode-glib to LD_LIBRARY_PATH. [inputs]: Add gnome-online-accounts:lib.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8005c46129..edb3b49841 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -131,7 +131,12 @@ topology functions.")
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(goa-path (string-append
(assoc-ref inputs "gnome-online-accounts")
+ "/lib:"
+ (assoc-ref inputs "gnome-online-accounts:lib")
"/lib"))
+ (geocode-glib-path (string-append
+ (assoc-ref inputs "geocode-glib")
+ "/lib"))
(webkitgtk-path (string-append
(assoc-ref inputs "webkitgtk")
"/lib")))
@@ -141,7 +146,8 @@ topology functions.")
;; There seems to be no way to embed the path of
;; libgoa-1.0.so.0, libwebkit2gtk-4.0.so.37 and
;; libjavascriptcoregtk-4.0.so.18.
- `("LD_LIBRARY_PATH" ":" prefix (,goa-path ,webkitgtk-path)))
+ `("LD_LIBRARY_PATH" ":" prefix
+ (,goa-path ,webkitgtk-path ,geocode-glib-path)))
#t))))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -163,6 +169,7 @@ topology functions.")
("gjs" ,gjs)
("glib" ,glib)
("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("rest" ,rest)
("webkitgtk" ,webkitgtk)))