summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-27 23:33:48 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-27 23:33:48 +0200
commit5cc1075a76392666d3d733837f5c6252b1e48002 (patch)
treeaff2a303881a6fe53021a6e78a767958e608719b /gnu/packages/geo.scm
parent9c2563a80b6f1d8fb8677f5314e6180ea9916aa5 (diff)
parentc30d117822a8ca26cd8c06c0a3974955bef68eac (diff)
downloadpatches-5cc1075a76392666d3d733837f5c6252b1e48002.tar
patches-5cc1075a76392666d3d733837f5c6252b1e48002.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 2c511c7193..2ee74794d8 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -872,3 +872,36 @@ dropping features at lower levels.")
OpenStreetMap project. They can be used to convert, filter and update
OpenStreetMap data files.")
(license license:agpl3)))
+
+(define-public osm-gps-map
+ (package
+ (name "osm-gps-map")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/nzjrs/osm-gps-map/releases/download/"
+ version "/osm-gps-map-" version ".tar.gz"))
+ (sha256
+ (base32
+ "11imsf4cz1dpxdjh178k2s29axmq86rkfg1pqmn7incyxmjzhbwg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gnome-common" ,gnome-common)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("libsoup" ,libsoup)))
+ (home-page "https://nzjrs.github.io/osm-gps-map/")
+ (synopsis "GTK+ widget for displaying OpenStreetMap tiles")
+ (description
+ "This package provides a GTK+ widget (and Python bindings) that when
+given GPS coordinates,draws a GPS track, and points of interest on a moving
+map display. Downloads map data from a number of websites, including
+@url{https://www.openstreetmap.org}.")
+ (license license:gpl2+)))