summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:53:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:38 +0200
commit82b47fd9d1b8e8fe660812e046388a45036a1cf7 (patch)
treeeec8cc102b156bdd991662d57c2e63310e1f9c97 /gnu/packages/geo.scm
parentf4daf2506697d43112126222f5de4f7c46007192 (diff)
downloadpatches-82b47fd9d1b8e8fe660812e046388a45036a1cf7.tar
patches-82b47fd9d1b8e8fe660812e046388a45036a1cf7.tar.gz
gnu: osm2pgsql: Don't use unstable tarball.
* gnu/packages/geo.scm (osm2pgsql)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d228b3edf5..5d0c5afa73 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -776,20 +776,21 @@ OpenStreetMap data.")
(package
(name "osm2pgsql")
(version "0.96.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openstreetmap/osm2pgsql/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "08y7776r4l9v9177a4q6cfdri0lpirky96m6g699hwl7v1vhw0mn"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "contrib/protozero")
- (delete-file-recursively "contrib/libosmium")
- #t))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openstreetmap/osm2pgsql.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "032cydh8ynaqfhdzmkvgbmqyjql668y6qln1l59l2s3ni9963bbl"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "contrib/protozero")
+ (delete-file-recursively "contrib/libosmium")
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f; tests fail because we need to setup a database