summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-27 16:20:46 -0400
committerLeo Famulari <leo@famulari.name>2017-07-27 16:22:18 -0400
commit201c0e72768fa92e2035512e16c17c07f308815b (patch)
tree2a753236e63e1f5c46ed017024479bd7996d1c5a /gnu/packages/gd.scm
parent70629b6d9a7fc48fdbe4667f99d004c9a99ba703 (diff)
downloadpatches-201c0e72768fa92e2035512e16c17c07f308815b.tar
patches-201c0e72768fa92e2035512e16c17c07f308815b.tar.gz
gnu: perl-gd-securityimage: Fix build with Perl 5.26.0.
* gnu/packages/gd.scm (perl-gd-securityimage)[arguments]: Set PERL_USE_UNSAFE_INC in new 'set-env' phase.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index aac0f9664c..b4e6ce435b 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -154,6 +154,11 @@ you can create PNG images on the fly or modify existing files.")
(base32
"1kaxs67rfd4w46lxgcg3pa05a596l0h1k8n4zk2gwrrar4022wpx"))))
(build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
(native-inputs
`(("perl-module-build" ,perl-module-build)))
(propagated-inputs