aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
commit99f63f011df2aab38e98d7ee4608a8c70bf74c4d (patch)
tree3f224028f30c60f2ed7b9846365ad926192fc7e9 /gnu/packages/gd.scm
parente9a8b603337802a77ff2d68f0d30dc0e67721e3a (diff)
parent4f03aa23e805bd653de774e1d74ed2f50826899b (diff)
downloadpatches-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar
patches-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 56553a6745..a53a4f2c2f 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -51,7 +51,10 @@
(sha256
(base32
"0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"
+
+ (patches (search-patches "gd-CVE-2018-5711.patch"
+ "gd-CVE-2018-1000222.patch"
+ "gd-fix-tests-on-i686.patch"
"gd-freetype-test-failure.patch"))))
(build-system gnu-build-system)
(arguments
@@ -94,7 +97,7 @@ most common applications of GD involve website development.")
(define-public perl-gd
(package
(name "perl-gd")
- (version "2.68")
+ (version "2.69")
(source
(origin
(method url-fetch)
@@ -102,7 +105,7 @@ most common applications of GD involve website development.")
"GD-" version ".tar.gz"))
(sha256
(base32
- "0p2ya641nl5cvcqgw829xgabh835qijfd6vq2ba12862946xx8va"))))
+ "0palmq7l42fibqxhrabnjm7di4q8kciq9323902d717x3i4jvc6x"))))
(build-system perl-build-system)
(inputs
`(("fontconfig" ,fontconfig)
@@ -139,7 +142,7 @@ you can create PNG images on the fly or modify existing files.")
'(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-env
- (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
(native-inputs
`(("perl-module-build" ,perl-module-build)))
(propagated-inputs