summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-10 01:37:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-10 01:37:32 +0200
commitfe79ce3b1f34300ff3bb94238462323f887c93be (patch)
tree050b264f8866b754ac3db918e02a870a746e58c8 /gnu/packages/gd.scm
parentfb94354a69cacbeed1a24d30c46ba7f056186b65 (diff)
parentd4bd2453ec6c2342d071cb9a9708280cf45b23ca (diff)
downloadpatches-fe79ce3b1f34300ff3bb94238462323f887c93be.tar
patches-fe79ce3b1f34300ff3bb94238462323f887c93be.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index c374695524..327a1f1545 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -39,6 +39,7 @@
(define-public gd
(package
(name "gd")
+ (replacement gd/fixed)
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
@@ -91,6 +92,16 @@ most common applications of GD involve website development.")
"See COPYING file in the distribution."))
(properties '((cpe-name . "libgd")))))
+(define-public gd/fixed
+ (hidden-package
+ (package
+ (inherit gd)
+ (source (origin
+ (inherit (package-source gd))
+ (patches (append (origin-patches (package-source gd))
+ (search-patches "gd-CVE-2018-5711.patch"
+ "gd-CVE-2018-1000222.patch"))))))))
+
(define-public perl-gd
(package
(name "perl-gd")