summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-26 14:24:43 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-26 22:35:35 +0100
commit736d772b82bfd693cd9412e2857e029fa6309269 (patch)
tree0935a47c181dbeda2f59502c0e63664e30ab450a /gnu/packages/gd.scm
parent8595c7b0bc84b354321ec8f6ccca54322f277eb6 (diff)
downloadpatches-736d772b82bfd693cd9412e2857e029fa6309269.tar
patches-736d772b82bfd693cd9412e2857e029fa6309269.tar.gz
gnu: gd: Update to 2.3.0.
* gnu/packages/patches/gd-fix-tests-on-i686.patch: Adjust context. * gnu/packages/patches/gd-CVE-2018-1000222.patch, gnu/packages/patches/gd-CVE-2018-5711.patch, gnu/packages/patches/gd-CVE-2019-6977.patch, gnu/packages/patches/gd-CVE-2019-6978.patch, gnu/packages/patches/gd-freetype-test-failure.patch: Delete files. * gnu/packages/patches/gd-brect-bounds.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly * gnu/packages/gd.scm (gd): Update to 2.3.0. [source](patches): Remove obsolete. * gnu/packages/gd.scm (gd): [propagated-inputs]: Move LIBJPEG-TURBO and FONTCONFIG ... [inputs]: ... here.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 444c76956a..3c818872c1 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -42,7 +42,7 @@
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.2.5")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -50,14 +50,9 @@
version "/libgd-" version ".tar.xz"))
(sha256
(base32
- "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
-
- (patches (search-patches "gd-CVE-2018-5711.patch"
- "gd-CVE-2018-1000222.patch"
- "gd-CVE-2019-6977.patch"
- "gd-CVE-2019-6978.patch"
- "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"))))
+ "0n5czhxzinvjvmhkf5l9fwjdx5ip69k5k7pj6zwb6zs1k9dibngc"))
+ (patches (search-patches "gd-fix-tests-on-i686.patch"
+ "gd-brect-bounds.patch"))))
(build-system gnu-build-system)
(arguments
;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
@@ -78,12 +73,11 @@
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("freetype" ,freetype)
+ `(("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("zlib" ,zlib)))
- (propagated-inputs
- `(("fontconfig" ,fontconfig)
- ("libjpeg" ,libjpeg-turbo)))
(home-page "https://www.libgd.org/")
(synopsis "Library for the dynamic creation of images by programmers")
(description