summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-08 16:24:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-08 16:24:29 +0200
commit72246dc0290246cc965770963667c3ae82cffa1a (patch)
tree36e43f19bc0b53791ed67068a2b4bd6e5da9dbea /gnu/packages/gcc.scm
parent5045d80ff120053a2f0b37f4c831e70d88291531 (diff)
downloadpatches-72246dc0290246cc965770963667c3ae82cffa1a.tar
patches-72246dc0290246cc965770963667c3ae82cffa1a.tar.gz
gnu: gcc@4.7: Build with texinfo@5.
* gnu/packages/gcc.scm (gcc@4.7)[native-inputs]: Use texinfo@5 in place of texinfo@6.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index bed277b1e0..9eb37957dc 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -155,7 +155,8 @@ where the OS part is overloaded to denote a specific ABI---into GCC
("zlib" ,zlib)))
;; GCC < 5 is one of the few packages that doesn't ship .info files.
- (native-inputs `(("texinfo" ,texinfo)))
+ ;; Newer texinfos fail to build the manual, so we use an older one.
+ (native-inputs `(("texinfo" ,texinfo-5)))
(arguments
`(#:out-of-source? #t
@@ -329,12 +330,7 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
- (patches (search-patches "gcc-arm-link-spec-fix.patch"))))
-
- ;; Texinfo 6.3 fails to build the manual:
- ;; ../../gcc-4.8.5/gcc/doc/gcc.texi:208: no matching `@end tex'
- ;; Use an older one.
- (native-inputs `(("texinfo" ,texinfo-5)))))
+ (patches (search-patches "gcc-arm-link-spec-fix.patch"))))))
(define-public gcc-4.9
(package (inherit gcc-4.7)
@@ -347,7 +343,8 @@ Go. It also includes runtime support libraries for these languages.")
(base32
"14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
(patches (search-patches "gcc-arm-bug-71399.patch"
- "gcc-libvtv-runpath.patch"))))))
+ "gcc-libvtv-runpath.patch"))))
+ (native-inputs `(("texinfo" ,texinfo)))))
(define-public gcc-5
;; Note: GCC >= 5 ships with .info files but 'make install' fails to install