summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
commitc3052d6bcd2193b258fb92b99291a4918931fe36 (patch)
tree0e0cbbc019e68f4f1c865b4d2f5e341eb45d96ee /gnu/packages/gcc.scm
parent0bfb9b439953b755a510974e51e651f79526a5a4 (diff)
parentb74f64a960542b0679ab13de0dd28adc496cf084 (diff)
downloadpatches-c3052d6bcd2193b258fb92b99291a4918931fe36.tar
patches-c3052d6bcd2193b258fb92b99291a4918931fe36.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 8b3c891c52..04d3f93369 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -328,7 +328,7 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
- (patches (list (search-patch "gcc-arm-link-spec-fix.patch")))))))
+ (patches (search-patches "gcc-arm-link-spec-fix.patch"))))))
(define-public gcc-4.9
(package (inherit gcc-4.8)
@@ -340,7 +340,7 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"0zmnm00d2a1hsd41g34bhvxzvxisa2l584q3p447bd91lfjv4ci3"))
- (patches (list (search-patch "gcc-libvtv-runpath.patch")))))))
+ (patches (search-patches "gcc-libvtv-runpath.patch"))))))
(define-public gcc-5
(package (inherit gcc-4.9)
@@ -352,10 +352,8 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
- (patches (list (search-patch "gcc-5.0-libvtv-runpath.patch")
- (search-patch
- "gcc-libiberty-printf-decl.patch")))))
-
+ (patches (search-patches "gcc-5.0-libvtv-runpath.patch"
+ "gcc-libiberty-printf-decl.patch"))))
;; GCC 5 ships with .info files, so no need for Texinfo.
(native-inputs '())))