summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-03-10 07:05:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-03-10 07:12:27 +0100
commit82f145ef7aef8f4d28a144ee8efcadf3fdd4b877 (patch)
tree9a2757e2202abd0c957584e6ebbe1af4358bf229 /gnu/packages/gcc.scm
parentce6027bf43210d0b68bb26dbf110ca6c47aa8478 (diff)
downloadpatches-82f145ef7aef8f4d28a144ee8efcadf3fdd4b877.tar
patches-82f145ef7aef8f4d28a144ee8efcadf3fdd4b877.tar.gz
gnu: custom-gcc: Delete broken or conflicting executables.
* gnu/packages/gcc.scm (custom-gcc)[arguments]: Add phase to remove executables that are non-functional or conflict with the executables of "gcc".
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index e15b07752b..73c6d488fb 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -440,7 +440,15 @@ as the 'native-search-paths' field."
`(cons (string-append "--enable-languages="
,(string-join languages ","))
(remove (cut string-match "--enable-languages.*" <>)
- ,flags)))))))
+ ,flags)))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'remove-broken-or-conflicting-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each delete-file
+ (find-files (string-append (assoc-ref outputs "out") "/bin")
+ ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc.*)"))
+ #t))))))))
(define %generic-search-paths
;; This is the language-neutral search path for GCC. Entries in $CPATH are