summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
committerAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
commit4ac0d6444d4edf38edc7c07331cf76deb4a506bc (patch)
tree5264c9c87172b8f0015823b0ee891d3672ac291a /gnu/packages/gcc.scm
parentd074e2f99130782e8eb7fa44c79c01db6c86f77d (diff)
parent7bde30e18de3e8cd7e4156ea5bb0d9439b6c12d7 (diff)
downloadpatches-4ac0d6444d4edf38edc7c07331cf76deb4a506bc.tar
patches-4ac0d6444d4edf38edc7c07331cf76deb4a506bc.tar.gz
Merge branch 'master' into core-updates.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index ca85073ea4..dbce52e2f2 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -327,6 +327,18 @@ Go. It also includes runtime support libraries for these languages.")
"1pbjp4blk2ycaa6r3jmw4ky5f1s9ji3klbqgv8zs2sl5jn1cj810"))
(patches (list (search-patch "gcc-arm-link-spec-fix.patch")))))))
+(define-public gcc-5.1
+ (package (inherit gcc-4.7)
+ (version "5.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1bd5vj4px3s8nlakbgrh38ynxq4s654m6nxz7lrj03mvkkwgvnmp"))
+ (patches (list (search-patch "gcc-arm-link-spec-fix.patch")))))))
+
(define* (custom-gcc gcc name languages #:key (separate-lib-output? #t))
"Return a custom version of GCC that supports LANGUAGES."
(package (inherit gcc)