aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-05-04 11:43:50 -0400
committerMark H Weaver <mhw@netris.org>2016-05-04 11:43:50 -0400
commit4e9d04a80b2d8b1e07f78708dae76b13f3d421f6 (patch)
tree18a163720f4c9fdd7a45d724c6584b065e216c6d /gnu/packages/gcc.scm
parentad1b7d8bafe96241fd87a74baec0a38ed4389e4b (diff)
parent11057c4b58d766f358bc439690b9765bee735772 (diff)
downloadpatches-4e9d04a80b2d8b1e07f78708dae76b13f3d421f6.tar
patches-4e9d04a80b2d8b1e07f78708dae76b13f3d421f6.tar.gz
Merge branch 'master' into gnome-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a2b8126872..c390a6659b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -354,6 +354,19 @@ Go. It also includes runtime support libraries for these languages.")
"1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
(patches (search-patches "gcc-5.0-libvtv-runpath.patch"))))))
+(define-public gcc-6
+ (package
+ (inherit gcc-5)
+ (version "6.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0ld3y4rgimyqgx1nwvzqyl5gr4wzc0ch4akkvsqp3fgbmdfcii09"))
+ (patches (search-patches "gcc-5.0-libvtv-runpath.patch"))))))
+
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions accordingly.
(define-public gcc gcc-4.9)