summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-07 10:52:04 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-07 10:52:04 +0200
commit9dee9e8ffe4650949bd3ad2edf559cf4a33e9e6e (patch)
treef6eef85e0c74b0c3e169a33271a8337f46866224 /gnu/packages/gcc.scm
parentaa81eb73ce6ee59c078331c709d553130e0443d3 (diff)
downloadpatches-9dee9e8ffe4650949bd3ad2edf559cf4a33e9e6e.tar
patches-9dee9e8ffe4650949bd3ad2edf559cf4a33e9e6e.tar.gz
Revert "gnu: Default to GCC 5."
This reverts commit e3d0fcbf7e55e8cbe8d0a1c5a24d73f341d7243b. This is a temporary measure until GCC 5 builds on ARM, see: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71399
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b8e13f3f8e..1ca8ca0d59 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -352,8 +352,7 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
- (patches (search-patches "gcc-5.0-libvtv-runpath.patch"
- "gcc-libiberty-printf-decl.patch"))))
+ (patches (search-patches "gcc-5.0-libvtv-runpath.patch"))))
;; GCC 5 ships with .info files, so no need for Texinfo.
(native-inputs '())))
@@ -372,7 +371,7 @@ Go. It also includes runtime support libraries for these languages.")
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions accordingly.
-(define-public gcc gcc-5)
+(define-public gcc gcc-4.9)
(define-public (make-libstdc++ gcc)
"Return a libstdc++ package based on GCC. The primary use case is when