summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-24 21:55:37 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-24 21:55:37 +0200
commit868c13c53a9788f8f27e77d8c8f99df14be512ba (patch)
treee3e785a76160dc77d0f14a2f13e2e22b4d13d597 /gnu/packages/gcc.scm
parent81068f178457db48f3e417e709d3dcf54268e23f (diff)
downloadpatches-868c13c53a9788f8f27e77d8c8f99df14be512ba.tar
patches-868c13c53a9788f8f27e77d8c8f99df14be512ba.tar.gz
gnu: gcc-5: Remove dependency on Texinfo.
* gnu/packages/gcc.scm (gcc-5): Set 'native-inputs' to '().
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1df5150ab3..1c9bd7dad6 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -153,7 +153,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
("libelf" ,libelf)
("zlib" ,zlib)))
- ;; GCC is one of the few packages that doesn't ship .info files.
+ ;; GCC < 5 is one of the few packages that doesn't ship .info files.
(native-inputs `(("texinfo" ,texinfo)))
(arguments
@@ -352,7 +352,10 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
- (patches (list (search-patch "gcc-5.0-libvtv-runpath.patch")))))))
+ (patches (list (search-patch "gcc-5.0-libvtv-runpath.patch")))))
+
+ ;; GCC 5 ships with .info files, so no need for Texinfo.
+ (native-inputs '())))
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions accordingly.