summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-08-04 18:54:47 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-04 19:38:33 +0200
commit7912677c1e4e9cf6746ac97e7937ba78b7b88bcb (patch)
tree9e23cc5b07fb7eeb62cc071b46b6f093ed1d7e0f /gnu/packages/gcc.scm
parente686e633ad4853bbff7a234155f75058fb896075 (diff)
downloadpatches-7912677c1e4e9cf6746ac97e7937ba78b7b88bcb.tar
patches-7912677c1e4e9cf6746ac97e7937ba78b7b88bcb.tar.gz
gnu: gcc: Reintroduce dependency on Texinfo.
This partly reverts 868c13c53a9788f8f27e77d8c8f99df14be512ba, which introduced a regression whereby gcc@5 and gcc@6 would no longer contain their Info manual. * gnu/packages/gcc.scm (gcc-5)[native-inputs]: Remove.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1ca8ca0d59..3236a4ebee 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -343,6 +343,8 @@ Go. It also includes runtime support libraries for these languages.")
(patches (search-patches "gcc-libvtv-runpath.patch"))))))
(define-public gcc-5
+ ;; Note: GCC >= 5 ships with .info files but 'make install' fails to install
+ ;; them in a VPATH build.
(package (inherit gcc-4.9)
(version "5.3.0")
(source (origin
@@ -352,9 +354,7 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
- (patches (search-patches "gcc-5.0-libvtv-runpath.patch"))))
- ;; GCC 5 ships with .info files, so no need for Texinfo.
- (native-inputs '())))
+ (patches (search-patches "gcc-5.0-libvtv-runpath.patch"))))))
(define-public gcc-6
(package