summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-02 19:14:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-02 19:14:26 +0300
commit721d7a69126113c4dd068a7c86f339cf5e96b69d (patch)
tree298c61dff7c52098f8c274668bb6c36acc94fab2 /gnu/packages/gcc.scm
parent696f1d0fb1d3f5211d9b38d0f70a5f5c9055a641 (diff)
downloadpatches-721d7a69126113c4dd068a7c86f339cf5e96b69d.tar
patches-721d7a69126113c4dd068a7c86f339cf5e96b69d.tar.gz
gnu: gcc@4.7: Don't built on aarch64.
* gnu/packages/gcc.scm (gcc@4.7, gcc@4.8, gcc@4.9)[supported-systems]: New field.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index f0e8dae3e8..bb8570bec5 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -340,6 +340,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
for several languages, including C, C++, Objective-C, Fortran, Java, Ada, and
Go. It also includes runtime support libraries for these languages.")
(license gpl3+)
+ (supported-systems (delete "aarch64-linux" %supported-systems))
(home-page "https://gcc.gnu.org/"))))
(define-public gcc-4.8
@@ -352,7 +353,8 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
- (patches (search-patches "gcc-arm-link-spec-fix.patch"))))))
+ (patches (search-patches "gcc-arm-link-spec-fix.patch"))))
+ (supported-systems %supported-systems)))
(define-public gcc-4.9
(package (inherit gcc-4.7)
@@ -366,7 +368,8 @@ Go. It also includes runtime support libraries for these languages.")
"14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
(patches (search-patches "gcc-arm-bug-71399.patch"
"gcc-libvtv-runpath.patch"))))
- (native-inputs `(("texinfo" ,texinfo)))))
+ (native-inputs `(("texinfo" ,texinfo)))
+ (supported-systems %supported-systems)))
(define-public gcc-5
;; Note: GCC >= 5 ships with .info files but 'make install' fails to install