aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-22 23:06:33 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-22 23:06:33 +0200
commitf07aa672fddd7b5405fc730ffebcda67daa71ae1 (patch)
tree52b2a3f246f5022ef7eaa7e20cb9aac067e10d05 /gnu/packages/gawk.scm
parent52ac153e2a83035ce2bc875f9c414cb26db5f6fc (diff)
parentdd68dd137a4a70cde7e344bd969ef7849355d018 (diff)
downloadpatches-f07aa672fddd7b5405fc730ffebcda67daa71ae1.tar
patches-f07aa672fddd7b5405fc730ffebcda67daa71ae1.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 718059e527..10506197f3 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -57,15 +57,12 @@
(string-append "### " match))))
'())
- ;; XXX FIXME gawk 4.1.1 was bootstrapped with a prerelease
- ;; libtool, which fails on MIPS in the absence of
- ;; /usr/bin/file. As a temporary workaround, we patch
- ;; the configure script to hardcode use of the little
- ;; endian N32 ABI on MIPS.
+ ;; XXX FIXME prerelease libtool fails on MIPS in the
+ ;; absence of /usr/bin/file.
,@(if (equal? "mips64el-linux" (or (%current-target-system)
(%current-system)))
'((substitute* "extension/configure"
- (("\\$emul") "elf32ltsmipn32")))
+ (("/usr/bin/file") (which "file"))))
'())))
%standard-phases)))
(inputs `(("libsigsegv" ,libsigsegv)