summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-11-17 14:51:23 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-11-30 18:19:32 +0530
commit3f3f8f494e97cea5c9c408fcd4051302a7b7eebe (patch)
tree93c5955984428a1568a7a9ec22fd28dadfee543b /gnu/packages/games.scm
parent92b51d127fa66a9f6cb59a2a295518c3487d705c (diff)
downloadpatches-3f3f8f494e97cea5c9c408fcd4051302a7b7eebe.tar
patches-3f3f8f494e97cea5c9c408fcd4051302a7b7eebe.tar.gz
gnu: pingus: Use scons-build-system.
* gnu/packages/games.scm (pingus): Switch to scons-build-system.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 565c0e8229..a699fadc2a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -808,7 +808,7 @@ fight Morgoth, the Lord of Darkness.")
(patches (search-patches "pingus-sdl-libs-config.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
- ("scons" ,scons)))
+ ("scons-python2" ,scons-python2)))
(inputs `(("sdl" ,sdl)
("sdl-image" ,sdl-image)
("sdl-mixer" ,sdl-mixer)
@@ -817,15 +817,11 @@ fight Morgoth, the Lord of Darkness.")
("libpng" ,libpng)
("boost" ,boost)))
(arguments
- '(#:tests? #f ; no check target
+ '(#:make-flags (list (string-append "PREFIX=" %output))
+ #:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "make" "install"
- (string-append "PREFIX="
- (assoc-ref outputs "out")))))))))
+ (delete 'configure)))) ; no configure script
(home-page "http://pingus.seul.org/welcome.html")
(synopsis "Lemmings clone")
(description