summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-08-01 22:37:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-08-02 12:19:37 +0300
commit7217d337550c9e5d64c4ad0ddfe75599fd47cd56 (patch)
tree4edf6e3f00b72e40f71759c84c1e1e1a0aeb2067 /gnu/packages/games.scm
parenta8253fbe5ff0371e783edc8bb949996f07dd643a (diff)
downloadpatches-7217d337550c9e5d64c4ad0ddfe75599fd47cd56.tar
patches-7217d337550c9e5d64c4ad0ddfe75599fd47cd56.tar.gz
gnu: minetest-data: Don't use autogenerated tarball.
* gnu/packages/games.scm (minetest-data)[source]: Download from git repository. [native-inputs]: Remove gzip, tar. [arguments]: Adjust custom build accordingly.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm32
1 files changed, 12 insertions, 20 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6d4ce1f17d..0174d5bfa2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1578,36 +1578,28 @@ match, cannon keep, and grave-itation pit.")
(name "minetest-data")
(version "0.4.17")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/minetest/minetest_game/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minetest/minetest_game")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0pa9skjwbq27aky6dgr7g3mb0a7c5rpa6xmz2qh0nm618z5hgazh"))))
+ "1g8iw2pya32ifljbdx6z6rpcinmzm81i9minhi2bi1d500ailn7s"))))
(build-system trivial-build-system)
(native-inputs
- `(("source" ,source)
- ("tar" ,tar)
- ("gzip" ,(@ (gnu packages compression) gzip))))
+ `(("source" ,source)))
(arguments
`(#:modules ((guix build utils))
#:builder (begin
(use-modules (guix build utils))
- (let ((tar (string-append (assoc-ref %build-inputs "tar")
- "/bin/tar"))
- (install-dir (string-append
+ (let ((install-dir (string-append
%output
- "/share/minetest/games/minetest_game"))
- (path (string-append (assoc-ref %build-inputs
- "gzip")
- "/bin")))
- (setenv "PATH" path)
- (invoke tar "xvf" (assoc-ref %build-inputs "source"))
- (chdir (string-append "minetest_game-" ,version))
+ "/share/minetest/games/minetest_game")))
(mkdir-p install-dir)
- (copy-recursively "." install-dir)
+ (copy-recursively
+ (assoc-ref %build-inputs "source")
+ install-dir)
#t))))
(synopsis "Main game data for the Minetest game engine")
(description