summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-31 14:54:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:54:59 +0200
commit51d4c79dc28c70cde61348eb52775f45125a2ee7 (patch)
treeaff7bac3184a7a098ced498e1f961a0115cbe37b /gnu/packages/games.scm
parentf9f72d35361bde53b8face634c72530aa7d81edf (diff)
downloadpatches-51d4c79dc28c70cde61348eb52775f45125a2ee7.tar
patches-51d4c79dc28c70cde61348eb52775f45125a2ee7.tar.gz
gnu: Remove workarounds for <https://bugs.gnu.org/36721>.
These are no longer needed since 941ef1a1e54893ca917ebbaa4b8cc14b5ce9b75c. * gnu/packages/compression.scm (innoextract)[arguments]: Remove "-DBoost_NO_BOOST_CMAKE=ON" from <#:configure-flags>. * gnu/packages/game-development.scm (openmw)[arguments]: Likewise. * gnu/packages/games.scm (supertux, colobot, leela-zero)[arguments]: Likewise. * gnu/packages/graphics.scm (openimageio)[arguments]: Likewise. * gnu/packages/ibus.scm (librime)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4e7fb2e428..66b642ebd2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3516,8 +3516,6 @@ with the \"Stamp\" tool within Tux Paint.")
(arguments
'(#:tests? #f
#:configure-flags '("-DINSTALL_SUBDIR_BIN=bin"
- ;; XXX: Work around <https://bugs.gnu.org/36721>.
- "-DBoost_NO_BOOST_CMAKE=ON"
"-DUSE_SYSTEM_PHYSFS=ON")
#:phases
(modify-phases %standard-phases
@@ -5390,8 +5388,6 @@ Github or Gitlab.")
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test
- ;; XXX: Work around <https://bugs.gnu.org/36721>.
- #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-git-checkout-writable
@@ -7616,9 +7612,7 @@ remake of that series or any other game.")
("qtbase" ,qtbase)
("zlib" ,zlib)))
(arguments
- '(#:configure-flags '("-DUSE_BLAS=YES"
- ;; XXX: Work around <https://bugs.gnu.org/36721>.
- "-DBoost_NO_BOOST_CMAKE=ON")
+ '(#:configure-flags '("-DUSE_BLAS=YES")
#:phases (modify-phases %standard-phases
(add-before 'configure 'fix-tests
(lambda* (#:key outputs #:allow-other-keys)