summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-13 16:49:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-13 17:07:16 +0300
commit18a613fb29bf053b344bca585e78a2cf26b44469 (patch)
tree6782a8bfad87a988b3280551012334f53edea846 /gnu/packages/games.scm
parentdbb0b06eb4cf8489a2eb413a8c63df0cac78d22a (diff)
downloadpatches-18a613fb29bf053b344bca585e78a2cf26b44469.tar
patches-18a613fb29bf053b344bca585e78a2cf26b44469.tar.gz
gnu: gnujump: Add desktop file.
This fixes bug#37069. * gnu/packages/games.scm (gnujump)[arguments]: Add custom 'create-desktop-entry phase to install a desktop file.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f9d7331f5b..c5ab05ed60 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2210,7 +2210,24 @@ also available.")
(modify-phases %standard-phases
(add-before
'configure 'link-libm
- (lambda _ (setenv "LIBS" "-lm"))))))
+ (lambda _ (setenv "LIBS" "-lm")))
+ (add-after 'install 'create-desktop-entry
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (apps (string-append out "/share/applications")))
+ (mkdir-p apps)
+ (with-output-to-file
+ (string-append apps "/gnujump.desktop")
+ (lambda _
+ (format #t
+ "[Desktop Entry]~@
+ Name=GNUjump~@
+ Comment=Jump up the tower to survive~@
+ Exec=~a/bin/gnujump~@
+ Terminal=false~@
+ Type=Application~@
+ Categories=Game;ArcadeGame~%"
+ out)))))))))
(inputs
`(("glu" ,glu)
("mesa" ,mesa)