summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
commitfc58cb5bd2f4a4fb9e910f553009fce8a60e56e9 (patch)
tree5a69fa6b63a7bfe7232cb98e949912c20775058d /gnu/packages/games.scm
parent9d89818a359dd0657e4eb7649b29ad4197b8db39 (diff)
parentbad368b0d794689f3a8a11b58f1ea4987938682e (diff)
downloadpatches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar
patches-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2f1fcd1879..8db9a7c529 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2961,20 +2961,14 @@ world}, @uref{http://evolonline.org, Evol Online} and
(define openttd-engine
(package
(name "openttd-engine")
- (version "1.9.3")
+ (version "1.10.0")
(source
(origin (method url-fetch)
- (uri (string-append "https://proxy.binaries.openttd.org/openttd-releases/"
+ (uri (string-append "https://cdn.openttd.org/openttd-releases/"
version "/openttd-" version "-source.tar.xz"))
(sha256
(base32
- "0ijq72kgx997ggw40i5f4a3nf7y2g72z37l47i18yjvgbdzy320r"))
- (modules '((guix build utils)))
- (snippet
- ;; The DOS port contains proprietary software.
- '(begin
- (delete-file-recursively "os/dos")
- #t))))
+ "0lz2y2rjc23k0d97y65cqhy2splw9cmrbvhgz0iqps8xkan1m8hv"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
@@ -3024,15 +3018,15 @@ engine. When you start it you will be prompted to download a graphics set.")
(define openttd-opengfx
(package
(name "openttd-opengfx")
- (version "0.5.5")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
- (uri (string-append "http://binaries.openttd.org/extra/opengfx/"
+ (uri (string-append "https://cdn.openttd.org/opengfx-releases/"
version "/opengfx-" version "-source.tar.xz"))
(sha256
(base32
- "009fa1bdin1bk0ynzhzc30hzkmmwzmwkk6j591ax3f6w75l28n49"))))
+ "0qxc6gl2gxcrn1np88dnjgbaaakkkx96b13rcmy1spryc8c09hyr"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc"
@@ -3062,6 +3056,7 @@ engine. When you start it you will be prompted to download a graphics set.")
("gimp" ,gimp)
("grfcodec" ,grfcodec)
("nml" ,nml)
+ ("which" ,which)
("python" ,python-2)))
(home-page "http://dev.openttdcoop.org/projects/opengfx")
(synopsis "Base graphics set for OpenTTD")