summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2017-02-10 16:45:11 -0600
committerChristopher Allan Webber <cwebber@dustycloud.org>2017-02-12 13:52:37 -0600
commitb76c94e639bd41f53d47d8d48ea696023d5aefdd (patch)
treeb33435e27b4817109fc8f19abd98001248699627 /gnu/packages/games.scm
parent83f805be02e75b366e1715ad62f50dd7dbd8ec89 (diff)
downloadpatches-b76c94e639bd41f53d47d8d48ea696023d5aefdd.tar
patches-b76c94e639bd41f53d47d8d48ea696023d5aefdd.tar.gz
gnu: Add angband.
* gnu/packages/games.scm (angband): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm53
1 files changed, 52 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0867089d5a..4bcdd484d6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -227,6 +227,57 @@ them, called Jean Raymond, found an old church in which to hide, not knowing
that beneath its ruins lay buried an ancient evil.")
(license license:gpl3)))
+(define-public angband
+ (package
+ (name "angband")
+ (version "4.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://rephial.org/downloads/4.0/"
+ "angband-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lpq2kms7hp421vrasx2bkkn9w08kr581ldwik3v0hlq6h7rlxhd"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; So, some of the sounds/graphics/tilesets are under different
+ ;; licenses... some of them even nonfree! This is a console-only
+ ;; version of this package so we just remove them.
+ ;; In the future, if someone tries to make a graphical variant of
+ ;; this package, they can deal with that mess themselves. :)
+ '(begin
+ (for-each
+ (lambda (subdir)
+ (let ((lib-subdir (string-append "lib/" subdir)))
+ (delete-file-recursively lib-subdir)))
+ '("fonts" "icons" "sounds" "tiles"))
+ (substitute* "lib/Makefile"
+ ;; And don't try to invoke makefiles in the directories we removed
+ (("gamedata customize help screens fonts tiles sounds icons user")
+ "gamedata customize help screens user"))))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no check target
+ #:configure-flags (list (string-append "--bindir=" %output "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen.sh
+ (lambda _
+ (substitute* "acinclude.m4"
+ (("ncursesw5-config") "ncursesw6-config"))
+ (zero? (system* "sh" "autogen.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs `(("ncurses" ,ncurses)))
+ (home-page "http://rephial.org/")
+ (synopsis "Dungeon exploration roguelike")
+ (description "Angband is a Classic dungeon exploration roguelike. Explore
+the depths below Angband, seeking riches, fighting monsters, and preparing to
+fight Morgoth, the Lord of Darkness.")
+ (license license:gpl2)))
+
(define-public pingus
(package
(name "pingus")