summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-01 15:53:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-01 15:53:17 +0200
commit4214066d45ec7030405577f225a9db0be04da1fd (patch)
tree2a0d3b6fd454b04721775a2d6846138658cc61ab /gnu/packages/games.scm
parent07ca7165f90079948e7174468b47ecc7cd38531d (diff)
parentae66fdaf9f7971c0a1b33d0c20844e903ccd909c (diff)
downloadpatches-4214066d45ec7030405577f225a9db0be04da1fd.tar
patches-4214066d45ec7030405577f225a9db0be04da1fd.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm87
1 files changed, 59 insertions, 28 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1082dadae6..6d4ce1f17d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2017, 2018 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -364,7 +364,7 @@ effects and music to make a completely free game.")
(define-public golly
(package
(name "golly")
- (version "3.1")
+ (version "3.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/golly/golly/golly-"
@@ -372,7 +372,7 @@ effects and music to make a completely free game.")
"-src.tar.gz"))
(sha256
(base32
- "0dn74k3rylhx023n047lz4z6qrqijfcxi0b6jryqklhmm2n532f7"))))
+ "0cg9mbwmf4q6qxhqlnzrxh9y047banxdb8pd3hgj3smmja2zf0jd"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc"
@@ -545,15 +545,15 @@ destroying an ancient book using a special wand.")
(define-public gnubg
(package
(name "gnubg")
- (version "1.02")
+ (version "1.06.001")
(source
(origin
(method url-fetch)
(uri (string-append "http://files.gnubg.org/media/sources/gnubg-release-"
- version ".000-sources." "tar.gz"))
+ version "-sources." "tar.gz"))
(sha256
(base32
- "015mvjk2iw1cg1kxwxfnvp2rxb9cylf6yc39i30fdy414k07zkky"))))
+ "0snz3j1bvr25ji7lg82bl2gm2s2x9lrpc7viw0hclgz0ql74cw7b"))))
(build-system gnu-build-system)
(inputs `(("glib" ,glib)
("readline" ,readline)
@@ -567,9 +567,9 @@ destroying an ancient book using a special wand.")
("pkg-config" ,pkg-config)))
(home-page "http://gnubg.org")
(synopsis "Backgammon game")
- (description "The GNU backgammon application can be used for playing, analyzing and
-teaching the game. It has an advanced evaluation engine based on artificial
-neural networks suitable for both beginners and advanced players. In
+ (description "The GNU backgammon application can be used for playing,
+analyzing and teaching the game. It has an advanced evaluation engine based on
+artificial neural networks suitable for both beginners and advanced players. In
addition to a command-line interface, it also features an attractive, 3D
representation of the playing board.")
(license license:gpl3+)))
@@ -875,7 +875,8 @@ role, and your gender.")
(copy-recursively "data" data)
- (install-file "COPYING" doc)))))))
+ (install-file "COPYING" doc)
+ #t))))))
(inputs
`(("python-sge-pygame" ,python-sge-pygame)
("python-six" ,python-six)
@@ -1617,7 +1618,7 @@ match, cannon keep, and grave-itation pit.")
(define-public minetest
(package
(name "minetest")
- (version "0.4.17")
+ (version "0.4.17.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1626,7 +1627,7 @@ match, cannon keep, and grave-itation pit.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0wpbad5bssbbgspgdcq3hhq4bhckrj53nhymsz34d8g01j0csr46"))))
+ "0ngb3h6hw0zbsr6isjpyp4fach0g4nbn6bxxv9g354plac6d89fd"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -2957,7 +2958,7 @@ fullscreen, use F5 or Alt+Enter.")
(define-public warzone2100
(package
(name "warzone2100")
- (version "3.2.1")
+ (version "3.2.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name
@@ -2965,10 +2966,11 @@ fullscreen, use F5 or Alt+Enter.")
".tar.xz"))
(sha256
(base32
- "1nd609s0g4sya3r4amhkz3f4dpdmm94vsd2ii76ap665a1nbfrhg"))))
+ "10kmpr4cby95zwqsl1zwx95d9achli6khq7flv6xmrq30a39xazw"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("--with-distributor=Guix")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'link-tests-with-qt
(lambda _
@@ -2976,24 +2978,22 @@ fullscreen, use F5 or Alt+Enter.")
(("(framework_linktest_LDADD|maptest_LDADD) = " prefix)
(string-append prefix "$(QT5_LIBS) ")))
#t))
- (add-after 'unpack 'remove-reference-to-missing-file
+ (add-after 'unpack 'fix-ivis-linktest
(lambda _
- (substitute* "icons/Makefile.in"
- (("\\$\\(INSTALL_DATA\\) \\$\\(srcdir\\)/warzone2100.appdata.xml.*") ""))
- #t))
- (add-after 'unpack 'patch-for-qt5.8
- (lambda _
- (substitute* "lib/widget/editbox.cpp"
- (("== '\\\\0'")
- "== QChar('\\0')"))
+ (substitute* "tests/ivis_linktest.cpp"
+ (("iV_DrawTextRotated.*;")
+ (string-append "iV_DrawTextRotated(\"Press ESC to exit.\", "
+ "100, 100, 0.0f, font_regular);")))
#t)))))
- (native-inputs `(("pkg-config" ,pkg-config)
+ (native-inputs `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
("unzip" ,unzip)
("zip" ,zip)))
(inputs `(("fontconfig" ,fontconfig)
("freetype" ,freetype)
("fribidi" ,fribidi)
("glew" ,glew)
+ ("harfbuzz" ,harfbuzz)
("libtheora" ,libtheora)
("libvorbis" ,libvorbis)
("libxrandr" ,libxrandr)
@@ -3002,7 +3002,6 @@ fullscreen, use F5 or Alt+Enter.")
("qtbase" ,qtbase)
("qtscript" ,qtscript)
("openssl" ,openssl)
- ("quesoglc" ,quesoglc)
("sdl2" ,sdl2)))
(home-page "http://wz2100.net")
(synopsis "3D Real-time strategy and real-time tactics game")
@@ -3621,7 +3620,7 @@ for Un*x systems with X11.")
(define-public freeciv
(package
(name "freeciv")
- (version "2.5.7")
+ (version "2.6.0")
(source
(origin
(method url-fetch)
@@ -3634,7 +3633,7 @@ for Un*x systems with X11.")
"/freeciv-" version ".tar.bz2")))
(sha256
(base32
- "1lmydnnqraa947l7gdz6xgm0bgks1ywsivp9h4v8jr3avcv6gqzz"))))
+ "16f9wsnn7073s6chzbm3819swd0iw019p9nrzr3diiynk28kj83w"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
@@ -4107,6 +4106,38 @@ laws of physics (Enigma’s special laws of physics, that is), controlling them
with the mouse isn’t always trivial.")
(license license:gpl2+)))
+(define-public chroma
+ (package
+ (name "chroma")
+ (version "1.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://level7.org.uk/chroma/download/chroma-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0nzm3j5wjazr1d6pkydqlc48sjf72hggq0hmx8mhq03114mmiir5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
+ ("freetype" ,freetype)
+ ("ncurses" ,ncurses)
+ ("fontconfig" ,fontconfig)
+ ("libxft" ,libxft)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://level7.org.uk/chroma/")
+ (synopsis "Abstract puzzle game")
+ (description "Chroma is an abstract puzzle game. A variety of colourful
+shapes are arranged in a series of increasingly complex patterns, forming
+ fiendish traps that must be disarmed and mysterious puzzles that must be
+ manipulated in order to give up their subtle secrets. Initially so
+ straightforward that anyone can pick it up and begin to play, yet gradually
+ becoming difficult enough to tax even the brightest of minds.")
+ (license license:gpl2+)))
+
(define-public fillets-ng
(package
(name "fillets-ng")