summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-26 14:58:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-26 14:58:02 +0100
commita4aca0b88cacad59373435385e4ed78dc451f197 (patch)
tree4bb60eab0d0a696c7b5f7906232ecb4f46d917e9 /gnu/packages/games.scm
parent482bdf2522f468263736302796e9ca04d2c27764 (diff)
downloadpatches-a4aca0b88cacad59373435385e4ed78dc451f197.tar
patches-a4aca0b88cacad59373435385e4ed78dc451f197.tar.gz
gnu: cmatrix: Use INVOKE.
* gnu/packages/games.scm (cmatrix)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1c9be1b394..9c782303e2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1363,9 +1363,8 @@ a C library, so they can easily be integrated into other programs.")
;; variables passed as arguments.
(let ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out))))))))
(inputs `(("ncurses" ,ncurses)))
(home-page "http://www.asty.org/cmatrix")
(synopsis "Simulate the display from \"The Matrix\"")