summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-10 10:55:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-10 14:04:28 +0100
commit8ada024ba69c6e8f72c69461c2322cddad88921b (patch)
tree6ddda4f2d65e9b4f016a97688eef19c422385c27 /gnu/packages/games.scm
parentc06709b8a496c2af91562ee8bfba538b51ec6c35 (diff)
downloadpatches-8ada024ba69c6e8f72c69461c2322cddad88921b.tar
patches-8ada024ba69c6e8f72c69461c2322cddad88921b.tar.gz
gnu: Add 4dtris.
* gnu/packages/games.scm (4dtris): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0dcf7eb879..410851ac8f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6145,3 +6145,50 @@ players attempt to shoot one another through a section of space populated by
planets. The main feature of the game is that the shots, once fired, are
affected by the gravity of the planets.")
(license license:gpl2+)))
+
+(define-public 4dtris
+ (package
+ (name "4dtris")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/4dtris/"
+ (version-major+minor version)
+ "/" version "/+download/4dtris_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32
+ "1nfkhcm0l89jyw8yr65na97g4l385zhjf7whkyg47c3v5sdqq2g7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-install-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile.in"
+ (("bindir = /usr/games")
+ (string-append "bindir = " out "/bin"))
+ (("/usr/share/applications")
+ (string-append out "/share/applications"))
+ (("/usr/share/games/4dtris")
+ (string-append out "/share/4dtris"))))
+ #t))
+ (add-after 'set-paths 'set-sdl-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CPATH"
+ (string-append (assoc-ref inputs "sdl")
+ "/include/SDL"))
+ #t)))))
+ (inputs
+ `(("fontconfig" ,fontconfig)
+ ("freeglut" ,freeglut)
+ ("sdl" ,(sdl-union (list sdl sdl-ttf)))))
+ (home-page "https://launchpad.net/4dtris/")
+ (synopsis "4D Tetris")
+ (description "4D-TRIS is an alteration of the well-known Tetris game. The
+game field is extended to 4D space, which has to filled up by the gamer with
+4D hyper cubes.")
+ (license license:gpl3)))
+