summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-26 14:57:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-26 14:57:29 +0100
commit482bdf2522f468263736302796e9ca04d2c27764 (patch)
treead94df28ffd4ca9cd1eca0541a7f20237e073c8d /gnu/packages/games.scm
parent4665d8c94325966a715e4a701fd593181dd76664 (diff)
downloadpatches-482bdf2522f468263736302796e9ca04d2c27764.tar
patches-482bdf2522f468263736302796e9ca04d2c27764.tar.gz
gnu: cowsay: Use INVOKE.
* gnu/packages/games.scm (cowsay)[arguments]: Use INVOKE in build phases.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2ab78f966b..1c9be1b394 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -338,14 +338,14 @@ and against the others like yourself, that want what you have.")
(delete 'build) ; nothing to be built
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "sh" "install.sh"
- (assoc-ref outputs "out")))))
+ (invoke "sh" "install.sh"
+ (assoc-ref outputs "out"))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* (string-append (assoc-ref outputs "out")
- "/bin/cowsay")
- "We're done!")))))))
+ (invoke (string-append (assoc-ref outputs "out")
+ "/bin/cowsay")
+ "We're done!"))))))
(inputs
`(("perl" ,perl)))
(home-page (string-append "https://web.archive.org/web/20071026043648/"