summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-23 21:40:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-23 21:41:16 +0200
commit472c36bd36696cfe744e8a7b8f4d4ac5800e0f68 (patch)
treec8f87fb72c5add933ee72b548f1fd25e8a84b89c /gnu/packages/games.scm
parent6556c00afa9057df2022df6c4b30d10312ef83ff (diff)
downloadpatches-472c36bd36696cfe744e8a7b8f4d4ac5800e0f68.tar
patches-472c36bd36696cfe744e8a7b8f4d4ac5800e0f68.tar.gz
gnu: pingus: Fix building.
* gnu/packages/games.scm (pingus)[source]: Use 'git-fetch'. Add patch to update used boost headers. * gnu/packages/patches/pingus-boost-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7b8d2f1bae..2ef93d6247 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1283,14 +1283,16 @@ fight Morgoth, the Lord of Darkness.")
(version "0.7.6")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Pingus/pingus/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Pingus/pingus.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0r9v6as5vi7skvvy7b0fcaimhdlzmik64pyy68plgljhsghqkkf4"))
- (patches (search-patches "pingus-sdl-libs-config.patch"))))
+ "0wp06kcmknsnxz7bjnsndb8x062z7r23fb3yrnbfnj68qhz18y74"))
+ (patches (search-patches "pingus-boost-headers.patch"
+ "pingus-sdl-libs-config.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("scons-python2" ,scons-python2)))