summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-03-05 18:40:00 +0100
committerAndreas Enge <andreas@enge.fr>2016-03-05 18:44:43 +0100
commitd7c4619bd10b3c965618d74d18d7982b2bd7ed3e (patch)
tree1feda3ec6f02a631864fa0fcc8024ec4617609ef /gnu/packages/games.scm
parent1068f26b797ed7c1475d93cab6eed53c9097c7f6 (diff)
downloadpatches-d7c4619bd10b3c965618d74d18d7982b2bd7ed3e.tar
patches-d7c4619bd10b3c965618d74d18d7982b2bd7ed3e.tar.gz
gnu: Add einstein.
* gnu/packages/games.scm (einstein): New variable. * gnu/packages/patches/einstein-build.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm52
1 files changed, 51 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a409f9cf21..9494e6853f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
@@ -70,6 +70,7 @@
#:use-module (gnu packages sdl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages check)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages bash)
@@ -1951,3 +1952,52 @@ players.")
(description
"DeSmuME is an emulator for the Nintendo DS handheld gaming console.")
(license license:gpl2)))
+
+(define-public einstein
+ (package
+ (name "einstein")
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://http.debian.net/debian/pool/main/e/"
+ "einstein/einstein_2.0.dfsg.2.orig.tar.gz"))
+ (sha256
+ (base32
+ "1hxrlv6n8py48j487i6wbb4n4vd55w0na69r7ccmmr9vmrsw5mlk"))
+ (patches (list (search-patch "einstein-build.patch")))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("freetype" ,freetype)
+ ("sdl" ,(sdl-union (list sdl sdl-mixer sdl-ttf)))
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("font-dejavu" ,font-dejavu)))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (dejavu (string-append (assoc-ref inputs "font-dejavu")
+ "/share/fonts/truetype/DejaVuSans.ttf")))
+ (substitute* "Makefile"
+ (("PREFIX=/usr/local") (string-append "PREFIX=" out)))
+ ;; The patch above registers a free font for use by the binary,
+ ;; but the font is copied during the compile phase into a
+ ;; resources file, so we need to make the ttf file available.
+ (symlink dejavu "res/DejaVuSans.ttf")
+ #t))))))
+ (synopsis "Logic puzzle game")
+ (description "The goal of this logic game is to open all cards in a 6x6
+grid, using a number of hints as to their relative position. The game idea
+is attributed to Albert Einstein.")
+ ;; The original home page has disappeared.
+ (home-page (string-append "http://web.archive.org/web/20120521062745/"
+ "http://games.flowix.com/en/index.html"))
+ ;; License according to
+ ;; http://web.archive.org/web/20150222180355/http://www.babichev.info/en/projects/index.html
+ ;; The source code is a DFSG-sanitized tarball and does not contain any
+ ;; license information.
+ (license license:gpl3+)))
+