summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-01 20:45:09 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2016-06-08 04:46:04 +0300
commitbcd2982fdf0c6a53175aa03f44ad51415d8b6b98 (patch)
tree37577d0c11fd88826abf6f8aceeae76c4a12edb2 /gnu/packages/games.scm
parentd0b6fed6b85661a761df87ce9ceb0074603e9608 (diff)
downloadpatches-bcd2982fdf0c6a53175aa03f44ad51415d8b6b98.tar
patches-bcd2982fdf0c6a53175aa03f44ad51415d8b6b98.tar.gz
gnu: Add higan.
* gnu/packages/games.scm (higan): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm93
1 files changed, 93 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 368f09632c..4181ffbcaa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2244,3 +2244,96 @@ Red Eclipse provides fast paced and accessible gameplay.")
license:cc-by-sa3.0
license:cc-by3.0
license:cc0)))))
+
+(define-public higan
+ (package
+ (name "higan")
+ (version "098")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/TaylanUB/higan/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "12snxrk8wa94x3l69qcimgm0xc22zjgf7vzhckp2lzyfbf27950v"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("ao" ,ao)
+ ("eudev" ,eudev)
+ ("gtk+" ,gtk+-2)
+ ("gtksourceview-2" ,gtksourceview-2)
+ ("libxv" ,libxv)
+ ("mesa" ,mesa)
+ ("openal" ,openal)
+ ("pulseaudio" ,pulseaudio)
+ ("sdl" ,sdl)))
+ (arguments
+ '(#:phases
+ (let ((build-phase (assoc-ref %standard-phases 'build))
+ (install-phase (assoc-ref %standard-phases 'install)))
+ (modify-phases %standard-phases
+ ;; The higan build system has no configure phase.
+ (delete 'configure)
+ (add-before 'build 'chdir-to-higan
+ (lambda _
+ (chdir "higan")))
+ (add-before 'install 'create-/share/applications
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; It seems the author forgot to do this in the Makefile.
+ (mkdir-p (string-append out "/share/applications")))))
+ (add-after 'install 'chdir-to-icarus
+ (lambda _
+ (chdir "../icarus")))
+ (add-after 'chdir-to-icarus 'build-icarus build-phase)
+ (add-after 'build-icarus 'install-icarus install-phase)
+ (add-after 'install-icarus 'wrap-higan-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (higan (string-append bin "/higan"))
+ (higan-original (string-append higan "-original"))
+ (bash (string-append (assoc-ref inputs "bash")
+ "/bin/bash"))
+ (coreutils (assoc-ref inputs "coreutils"))
+ (mkdir (string-append coreutils "/bin/mkdir"))
+ (cp (string-append coreutils "/bin/cp"))
+ (cp-r (string-append cp " -r --no-preserve=mode")))
+ ;; First, have the executable make sure ~/.local/share/higan
+ ;; contains up to date files. Higan insists on looking there
+ ;; for these data files.
+ (rename-file higan higan-original)
+ (with-output-to-file higan
+ (lambda ()
+ (display
+ (string-append
+ "#!" bash "\n"
+ ;; higan doesn't respect $XDG_DATA_HOME
+ mkdir " -p ~/.local/share\n"
+ cp-r " " out "/share/higan ~/.local/share\n"
+ "exec " higan-original))))
+ (chmod higan #o555)
+ ;; Second, make sure higan will find icarus in PATH.
+ (wrap-program higan
+ `("PATH" ":" prefix (,bin))))))))
+ #:make-flags
+ (list "compiler=g++"
+ (string-append "prefix=" (assoc-ref %outputs "out")))
+ ;; There is no test suite.
+ #:tests? #f))
+ (home-page "http://byuu.org/emulation/higan/")
+ (synopsis "Nintendo multi-system emulator")
+ (description
+ "higan (formerly bsnes) is an emulator for multiple Nintendo video game
+consoles, including the Nintendo Entertainment System (NES/Famicom), Super
+Nintendo Entertainment System (SNES/Super Famicom), Game Boy, Game Boy
+Color (GBC), and Game Boy Advance (GBA). It also supports the subsystems
+Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
+ ;; As noted in these files among more:
+ ;; - icarus/icarus.cpp
+ ;; - higan/emulator/emulator.hpp
+ (license license:gpl3)))