summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 23:40:08 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:45 +0100
commitcc1cca9ffbda61d5b6ce4f7bbe23e3c5efee0b3b (patch)
tree800ea68947d61d0a1bfaa767cd1781a35fa9ca95 /gnu/packages/games.scm
parent601f29cd73cdeefd6f00bdc3a42c34f8266823f0 (diff)
downloadpatches-cc1cca9ffbda61d5b6ce4f7bbe23e3c5efee0b3b.tar
patches-cc1cca9ffbda61d5b6ce4f7bbe23e3c5efee0b3b.tar.gz
gnu: Add kblackbox.
* gnu/packages/games.scm (kblackbox): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 84da7ab989..4968a860b0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8638,3 +8638,45 @@ grid, the winner being the first to place four pieces in a line.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
+(define-public kblackbox
+ (package
+ (name "kblackbox")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kblackbox-" version ".tar.xz"))
+ (sha256
+ (base32 "1x42sfpf75c6mavwkc7g7dm11y9s5dpj8igphly5kvm0pajqby0n"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("karchive" ,karchive)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Find atoms in a grid by shooting electrons")
+ (description "KBlackbox is a game of hide and seek played on a grid of
+boxes where the computer has hidden several balls. The position of the hidden
+balls can be deduced by shooting beams into the box
+
+KBlackBox is a game of hide and seek played on an grid of boxes, where the
+player shoots rays into the grid to deduce the positions of hidden objects.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))