summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 13:34:29 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 13:44:00 +0100
commitc97e4d8bbe8bf12c09471573d3544d08a42d83f5 (patch)
treea089ac8826cc4a315f6a2fde9c83cc639bfe3586 /gnu/packages/games.scm
parent973bd8a62c13bc5b2ca08585c367589d8c7197fe (diff)
downloadpatches-c97e4d8bbe8bf12c09471573d3544d08a42d83f5.tar
patches-c97e4d8bbe8bf12c09471573d3544d08a42d83f5.tar.gz
gnu: gnubg: Rename package to gnubackgammon.
* gnu/packages/games.scm (gnubg): Define in terms of 'deprecated-package'. (gnubackgammon): New variable, formerly known as "gnubg".
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 41b1d8448d..dcee2c2d00 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -662,9 +662,9 @@ destroying an ancient book using a special wand.")
;; license. The whole package is released under GPLv3+.
(license license:gpl3+)))
-(define-public gnubg
+(define-public gnubackgammon
(package
- (name "gnubg")
+ (name "gnubackgammon")
(version "1.06.002")
(source
(origin
@@ -687,13 +687,16 @@ destroying an ancient book using a special wand.")
("pkg-config" ,pkg-config)))
(home-page "http://gnubg.org")
(synopsis "Backgammon game")
- (description "The GNU backgammon application can be used for playing,
-analyzing and teaching the game. It has an advanced evaluation engine based on
-artificial neural networks suitable for both beginners and advanced players. In
-addition to a command-line interface, it also features an attractive, 3D
-representation of the playing board.")
+ (description "The GNU backgammon application (also known as \"gnubg\") can
+be used for playing, analyzing and teaching the game. It has an advanced
+evaluation engine based on artificial neural networks suitable for both
+beginners and advanced players. In addition to a command-line interface, it
+also features an attractive, 3D representation of the playing board.")
(license license:gpl3+)))
+(define-public gnubg
+ (deprecated-package "gnubg" gnubackgammon))
+
(define-public gnubik
(package
(name "gnubik")