summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 13:40:51 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 13:44:00 +0100
commit36a0b5b48c8f14e2ac5707dd6dfea99ee2304873 (patch)
treebf390753710ef2116dc10636d8b44aade372efca /gnu/packages/games.scm
parent8b6e2bc15f0cbbe325f45fff9a7b5d3df143ca53 (diff)
downloadpatches-36a0b5b48c8f14e2ac5707dd6dfea99ee2304873.tar
patches-36a0b5b48c8f14e2ac5707dd6dfea99ee2304873.tar.gz
gnu: crawl: Rename package to dungeon-crawl-stone-soup.
* gnu/packages/games.scm (crawl): Define in terms of 'deprecated-package'. (dungeon-crawl-stone-soup): New variable, formerly known as "crawl".
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6b40ac68cf..e328564c86 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4436,9 +4436,9 @@ fish. The whole game is accompanied by quiet, comforting music.")
(define-public fillets-ng
(deprecated-package "fillets-ng" fish-fillets-ng))
-(define-public crawl
+(define-public dungeon-crawl-stone-soup
(package
- (name "crawl")
+ (name "dungeon-crawl-stone-soup")
(version "0.23.1")
(source
(origin
@@ -4504,9 +4504,9 @@ fish. The whole game is accompanied by quiet, comforting music.")
;; Force command line build for test cases.
(append make-flags '("GAME=crawl" "TILES="))))))))
(synopsis "Roguelike dungeon crawler game")
- (description "Dungeon Crawl Stone Soup is a roguelike adventure through
-dungeons filled with dangerous monsters in a quest to find the mystifyingly
-fabulous Orb of Zot.")
+ (description "Dungeon Crawl Stone Soup (also known as \"Crawl\" or DCSS
+for short) is a roguelike adventure through dungeons filled with dangerous
+monsters in a quest to find the mystifyingly fabulous Orb of Zot.")
(home-page "https://crawl.develz.org")
(license (list license:gpl2+
license:bsd-2
@@ -4516,6 +4516,9 @@ fabulous Orb of Zot.")
license:zlib
license:asl2.0))))
+(define-public crawl
+ (deprecated-package "crawl" dungeon-crawl-stone-soup))
+
;; The linter here claims that patch file names should start with the package
;; name. But, in this case, the patches are inherited from crawl with the
;; "crawl-" prefix instead of "crawl-tiles-".