summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-18 21:07:30 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-18 21:52:45 +0300
commit147367271c2daef0869ed6538fbe9f76a6765af7 (patch)
treedb9c336f98b5c795f8ae5a4df14facfc08f99f12 /gnu/packages/games.scm
parent2072bc08385a2703ef7beb1227bf8faae678072a (diff)
downloadpatches-147367271c2daef0869ed6538fbe9f76a6765af7.tar
patches-147367271c2daef0869ed6538fbe9f76a6765af7.tar.gz
gnu: cmatrix: Update to 2.0.
* gnu/packages/games.scm (cmatrix)[version]: Update to 2.0. [source]: Download using git-fetch. [native-inputs]: Add AUTOCONF and AUTOMAKE.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fefb3055a8..dd4e5993c5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1631,16 +1631,21 @@ a C library, so they can easily be integrated into other programs.")
(define-public cmatrix
(package
(name "cmatrix")
- (version "1.2a")
+ (version "2.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.asty.org/cmatrix/dist/cmatrix-" version
- ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abishekvashok/cmatrix.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0k06fw2n8nzp1pcdynhajp5prba03gfgsbj91bknyjr5xb5fd9hz"))))
+ "1h9jz4m4s5l8c3figaq46ja0km1gimrkfxm4dg7mf4s84icmasbm"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
(arguments
'(#:phases
(modify-phases %standard-phases