summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 18:54:40 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:46 +0100
commitf2f0ef92f70ce9dbe008894105377c71a863f1ff (patch)
treebcc2208698b979c63fe39fe1fb320cb8471f4bfb /gnu/packages/games.scm
parent2fbf14e1d0ac04d3bd5e729be8c2c9ad3c5a6f53 (diff)
downloadpatches-f2f0ef92f70ce9dbe008894105377c71a863f1ff.tar
patches-f2f0ef92f70ce9dbe008894105377c71a863f1ff.tar.gz
gnu: Add ksnakeduel.
* gnu/packages/games.scm (ksnakeduel): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0a049c0920..a15f357e8a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9241,3 +9241,43 @@ are your only weapons against the never-ending stream of mindless automatons.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public ksnakeduel
+ (package
+ (name "ksnakeduel")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/ksnakeduel-" version ".tar.xz"))
+ (sha256
+ (base32 "0mprrnpax8pv7ab36zwhvdfj8id52w8g6x76nnj8qvkdlkjiqdnn"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Snake race played against the computer")
+ (description "KSnakeDuel is a fast action game where you steer a snake
+which has to eat food. While eating the snake grows. But once a player
+collides with the other snake or the wall the game is lost. This becomes of
+course more and more difficult the longer the snakes grow.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))