summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 18:03:16 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:46 +0100
commited88e67d56a471f6dd75266c2c79affa0c83664a (patch)
tree46e08f4dae540e424f19fd8d51fe34051ac54a4b /gnu/packages/games.scm
parent01e2f2eddbeb827f128a17b04d05477124699034 (diff)
downloadpatches-ed88e67d56a471f6dd75266c2c79affa0c83664a.tar
patches-ed88e67d56a471f6dd75266c2c79affa0c83664a.tar.gz
gnu: Add kapman.
* gnu/packages/games.scm (kapman): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2242229f9a..1f9864ce8b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9082,3 +9082,44 @@ Lieutnant Skat is a simplified variant of the Skat card game for two players.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
+(define-public kapman
+ (package
+ (name "kapman")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kapman-" version ".tar.xz"))
+ (sha256
+ (base32 "03pq38caam30q4bw14c045kayw2d87xq1yaa3s2jkrylylfq3p0f"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Pac-Man clone")
+ (description "Kapman is a clone of the well known game Pac-Man.
+
+You must run through the maze to eat all pills without being captured by a
+ghost. By eating an energizer, Kapman gets the ability to eat ghosts for a
+few seconds. When a stage is cleared of pills and energizer the player is
+taken to the next stage with slightly increased game speed
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))